[debian/fso] Re: starting kde on debian

Jos vd Snepscheut jos at snepscheut.nl
Sun Dec 21 01:20:48 CET 2008

arne anka wrote:
> <div class="moz-text-flowed" style="font-family: -moz-fixed">> can you 
> help me a little bit more please:
>> I have downloaded the python-evas from http://www.ginguppin.de/node/24
>> and I have been searching and reading about .deb and how to install 
>> them.
>> But I can't make out how to do it....
> oh, just the usual debian way.
> for starters, the output of
> DISPLAY=:0 zhone
> would have been nice, to confirm it is really the issue i suspect.
Yes your right and yes it was the issue yuo suspected!
> if so the next step is to download both packages from their respective 
> locations and install via
> dpkg -i cython*deb
> dpkg -i python-evas*deb
> to be on the safe side, substitute the names with the full ones (don't 
> have them handy right now).
Ok this is what I needed (I'm not a debian user my flavor is Mandriva 
witch is using rpm.)

> if for some reason installation fails, because a dependency is 
> missing, apt-cache is helpful:
> apt-cache show libevas0
> produces the following output:
> Package: libevas0
> Priority: optional
> Section: libs
> Installed-Size: 848
> Maintainer: Debian Pkg-e Team <pkg-e-devel at lists.alioth.debian.org>
> Architecture: armel
> Source: evas
> Version:
> Depends: libc6 (>= 2.7-1), libcairo2 (>= 1.2.4), libeet1 (>= 1.1.0), 
> libfontconfig1 (>= 2.4.0), libfreetype6 (>= 2.3.5), libgcc1 (>= 
> 1:4.3), libgif4 (>= 4.1.6), libglib2.0-0 (>= 2.12.0), libgtk2.0-0 (>= 
> 2.12.0), libjpeg62, libpng12-0 (>= 1.2.13-4), librsvg2-2 (>= 2.18.1), 
> libtiff4, zlib1g (>= 1:1.1.4)
> Recommends: libevas-engines
> Filename: pool/main/e/evas/libevas0_0.9.9.050-2_armel.deb
> Size: 260460
> MD5sum: d3106461470bf0ae680233797fdf43c0
> SHA1: 0dd27f6687b5a1ef7f19401f7515b1c3382e81aa
> SHA256: f0d2a47012992a0cd4dee98f1222891398403fb74cc197cebfb354a74e36c950
> Description: Enlightenment DR17 advanced canvas library
>  Evas is an advanced canvas library, providing six engines for 
> rendering: X11,
>  OpenGL (hardware accelerated), DirectFB, the framebuffer, Microsoft 
> Windows
>  and Qtopia.
>  .
>  Due to its simple API, evas can be developed with rapidly, and cleanly.
>  .
>  This package contains the core library and a set of image loaders 
> there  and/or savers
>  for various formats: eet, gif, jpeg, png, svg, tiff and xpm
> Homepage: http://www.enlightenment.org
No there is no need for this it installs fine and Zhone now is running.

> the line beginning with "Filename: " shows the path to the missing 
> package inside the repo, here
> pool/main/e/evas/libevas0_0.9.9.050-2_armel.deb
> if your installation is a default one, the repo will be
> http://ftp2.de.debian.org/debian
> so you have to point your browser/wget/whatever to
> http://ftp2.de.debian.org/debian/pool/main/e/evas/libevas0_0.9.9.050-2_armel.deb 
> this is rather informational! if you are not familiar with either dpkg 
> or apt, you should refrain from wildly installing and better ask here 
> together with the output from dpkg to get help!
> after that starting zhone should work -- if not, it's probably 
> another/additional error. starting zhone like said above in such cases 
> produces useful, nay, necessary output, so please append.
So zhone is now working fine. but I have a lot to learn thank you for 
pointing me in ther right direction.

if I may ask an other question:
how can I add new programs to zhone/freerunner: I would like to use an 
agenda, navigation prog (something like tomtom), and a today screen.

Thanks for helping me,


> </div>

More information about the community mailing list