2008.12 and USB network Ubuntu Intrepid

Simon Kagstrom simon.kagstrom at gmail.com
Mon Dec 22 11:57:07 CET 2008

On Mon, 22 Dec 2008 02:51:35 -0800 (PST)
Bernt <bernt at trash-mail.com> wrote:

> > On FR I've installed 2008.12 and on my laptop Ubuntu Interpid with
> > wicd.
> > 
> I have to use `sudo ifdown usb0` and `sudo ifup usb0` 
> every time I reboot or unplugged the usb cable from my freerunner.
> It's not so nice, but you can give it a try until there is a solution 
> again for automatic reconnect.

Probably there is some proper fix to get this running "cleanly", but I
resorted to a simple script that simply configures the interface when I
plug in the freerunner. It's found below and I just start it manually
once after logging in.

// Simon


echo "Starting ifcfg daemon"
while [ 1 ]; do
      tail -F /var/log/kern.log | grep -lq "usb0: register 'cdc_ether'"
      if [ $? -eq 0 ]; then
          echo "Setting up usb0"
          /sbin/ifconfig usb0
          sleep 1

More information about the community mailing list