[2008.12] Enlightenment not starting anymore.

Ivar Mossin ivar.mossin at gmail.com
Thu Dec 25 16:15:51 CET 2008


I have a problem with starting enlightenment. Unfortunately I do not know
what caused it to stop working. I shut down the phone one day and everything
was seemingly working. Then two days later I wanted to play with the
openmoko again and booted up, but it stopped in text-mode.

With some help from IRC, I figured it is enlightenment not starting.
Enlightenment seemingly can't find it's prefix directory. Setting the
environment-variable E_PREFIX to "/usr" (which is the hard-coded default
anyway), it gives a clue. It is looking for the file
/usr/share/enlightenment/data/themes/default.edj, which does not exist. But
this is strange, as it didn't exist on the jffs2 flash image either.

I thought something had gone wrong with enlightenment, so I decided to
reinstall e-wm by using opkg e-wm remove. This was not possible without
removing most of the installed software on the phone, so I decided to ignore
its dependencies by using:
$ opkg remove e-wm -force-depends

Then I wanted to installed it again from repository:
$ opkg install e-wm
Installing e-wm (0.16.999.050+svnr37988-r0.1) to root...
Collected errors:
 * ERROR: Package e-wm (parent e-wm) is not available from any configured
 * Failed to download e-wm. Perhaps you need to run 'opkg update'?

What is this message actually saying? Apparently it does find the e-wm
package in the repository (as it's able to find its versioning numbers), but
then reports e-wm not available? How do I install this package?
root at om-gta02:~# opkg list | grep e-wm
e-wm - 0.16.999.043+svnr36882-r14.01 - The Enlightenment Window Manager
Version 17
e-wm - 0.16.999.050+svnr37988-r0.1 -
e-wm-dbg - 0.16.999.043+svnr36882-r14.01 - The Enlightenment Window Manager
Version 17
e-wm-dev - 0.16.999.043+svnr36882-r14.01 - The Enlightenment Window Manager
Version 17
e-wm-fm-data - 0.16.999.043+svnr36882-r14.01 - The Enlightenment Window
Manager Version 17
e-wm-locale-bg - 0.16.999.043+svnr36882-r14.01 - bg translation for e-wm
e-wm-locale-ca - 0.16.999.043+svnr36882-r14.01 - ca translation for e-wm
e-wm-locale-de - 0.16.999.043+svnr36882-r14.01 - de translation for e-wm
e-wm-locale-eo - 0.16.999.043+svnr36882-r14.01 - eo translation for e-wm
e-wm-locale-es - 0.16.999.043+svnr36882-r14.01 - es translation for e-wm
e-wm-locale-fi - 0.16.999.043+svnr36882-r14.01 - fi translation for e-wm
e-wm-locale-fr - 0.16.999.043+svnr36882-r14.01 - fr translation for e-wm
e-wm-locale-fr-ch - 0.16.999.043+svnr36882-r14.01 - fr_CH translation for
e-wm-locale-hu - 0.16.999.043+svnr36882-r14.01 - hu translation for e-wm
e-wm-locale-it - 0.16.999.043+svnr36882-r14.01 - it translation for e-wm
e-wm-locale-ja - 0.16.999.043+svnr36882-r14.01 - ja translation for e-wm
e-wm-locale-ko - 0.16.999.043+svnr36882-r14.01 - ko translation for e-wm
e-wm-locale-pt-br - 0.16.999.043+svnr36882-r14.01 - pt_BR translation for
e-wm-locale-ru - 0.16.999.043+svnr36882-r14.01 - ru translation for e-wm
e-wm-locale-sl - 0.16.999.043+svnr36882-r14.01 - sl translation for e-wm
e-wm-locale-zh-cn - 0.16.999.043+svnr36882-r14.01 - zh_CN translation for
e-wm-locale-zh-tw - 0.16.999.043+svnr36882-r14.01 - zh_TW translation for
e-wm-theme-default - 0.16.999.043+svnr36882-r14.01 - The Enlightenment
Window Manager Version 17
$ opkg list_installed | grep e-wm

I might have made things worse by actually copying the raw files from the
flash image onto the phone:
scp /mnt/jffs2/usr/bin/enlightenment* root at
scp -r /mnt/jffs2/usr/lib/enlightenment/* root at
... etc...

But at least this brought me back to where I started (except enlightenment
is installed, but not in opkgs' database). It is still looking for this
nonexisting file. I also tried to remove ~/.e/ directory, with no luck.
After starting X, the /tmp/x.log file looks like this:

(II) verbosity set to 5
Using GLAMO 3362 card
(II) Screen: 16/16 depth/bpp
(II) vram size:4194304, onscreen vram size:614400, offscreen vram
(II) initialising offscreen pixmaps
Extended Input Devices not yet supported. Impelement it at line 647 in
D-BUS per-session daemon address is:
[settings daemon] Forking. run with -n to prevent fork
ESTART: 0.00010 [0.00010] - begin
ESTART: 0.00194 [0.00185] - signals done
ESTART: 0.01848 [0.01654] - determine prefix
WARNING: Prefix guess was wrong. Guessed:
         Tried to find file:
WARNING: Enlightenment could not determine its installed prefix
         and is falling back on the compiled in default:
         You might like to try setting the following environment variables:
           E_PREFIX     - points to the base prefix of install
           E_BIN_DIR    - optional in addition to E_PREFIX to provide
                          a more specific binary directory
           E_LIB_DIR    - optional in addition to E_PREFIX to provide
                          a more specific library dir
           E_DATA_DIR   - optional in addition to E_PREFIX to provide
                          a more specific location for shared data
           E_LOCALE_DIR - optional in addition to E_PREFIX to provide
                          a more specific location for locale data
ESTART: 0.02022 [0.00174] - prefix done
ESTART: 0.02147 [0.00125] - intl init
ESTART: 0.02263 [0.00115] - parse args
ESTART: 0.02331 [0.00068] - arg parse done
ESTART: 0.02397 [0.00066] - ecore init
ESTART: 0.28864 [0.26467] - ecore_file init
ESTART: 0.30839 [0.01975] - more ecore
ESTART: 0.30899 [0.00060] - x connect
run-parts: /etc/X11/Xsession.d/90xXWindowManager exited with code 1011
waiting for X server to shut down FreeFontPath: FPE "built-ins" refcount is
2, should be 1; fixing.


How to solve this? Any clues? A fresh reflash will probably solve the issue,
but that means I would have to spend quite some time installing my software
and stuff over again, and I will probably learn very little from it.

Thanks for any help. I'll try to be patient enought not to reflash it
immediately. :)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.openmoko.org/pipermail/community/attachments/20081225/fc2436e2/attachment.htm 

More information about the community mailing list