[2008.12] Enlightenment not starting anymore.

Ivar Mossin ivar.mossin at gmail.com
Sat Dec 27 01:25:17 CET 2008

> On Thu, 25 Dec 2008 16:15:51 +0100, "Ivar Mossin" <ivar.mossin at gmail.com <http://lists.openmoko.org/mailman/listinfo/community>>
> wrote:
> >* anyway), it gives a clue. It is looking for the file
*> >* /usr/share/enlightenment/data/themes/default.edj, which does not exist.
*> >* But
*> >* this is strange, as it didn't exist on the jffs2 flash image either.
*> >*
*> >* I thought something had gone wrong with enlightenment, so I decided to
*> >* reinstall e-wm by using opkg e-wm remove. This was not possible without
*> >* removing most of the installed software on the phone, so I decided to
*> >* ignore
*> >* its dependencies by using:
*> >* $ opkg remove e-wm -force-depends
*> >*
*> >* Then I wanted to installed it again from repository:
*> >* $ opkg install e-wm
*> >* Installing e-wm (0.16.999.050+svnr37988-r0.1) to root...
*> >* Collected errors:
*> >*  * ERROR: Package e-wm (parent e-wm) is not available from any configured
*> >* src.
*> >*  * Failed to download e-wm. Perhaps you need to run 'opkg update'?
*> >*
*> >*
*> >* What is this message actually saying? Apparently it does find the e-wm
*> >* package in the repository (as it's able to find its versioning numbers),
*> >* but
*> >* then reports e-wm not available? How do I install this package?
*> >* root at om-gta02
<http://lists.openmoko.org/mailman/listinfo/community>:~# opkg list |
grep e-wm
*> >* e-wm - 0.16.999.043+svnr36882-r14.01 - The Enlightenment Window Manager
*> >* Version 17
*> >* e-wm - 0.16.999.050+svnr37988-r0.1 -
*> >* e-wm-theme-default - 0.16.999.043+svnr36882-r14.01 - The Enlightenment
*> >* Window Manager Version 17

> You need to "opkg update" - somehow you've got two versions of e-wm listed
> in the local (IE on the FreeRunner) package list.  I'm not sure how that
> happened, unless you added a repository to the config.  (check in
> /etc/opkg)   "svnr36882-r14.01" is the latest in the OM2008 repository,
> which matches with the svn versions of the other enlightenment packages
> you're seeing in 'opkg list', I don't know where it's getting the reference
> to "svnr37988-r0.1"...  When you run 'opkg upgrade' or 'opkg list' it's NOT
> looking at the repository itself, it's looking at the package list locally
> on the FreeRunner that is constructed during 'opkg update'.  THAT list
> contains a 'newer' version of e-wm (37988) so it picks that one, being the
> newest, but cannot actually find the package in the repository when it
> tries to download.
> For a quick fix (which might fix enlightenment but not address the cause of
> this problem) try:
> opkg install
> http://downloads.openmoko.org/repository/Om2008.8/armv4t/e-wm_0.16.999.043+svnr36882-r14.01_armv4t.opk <http://downloads.openmoko.org/repository/Om2008.8/armv4t/e-wm_0.16.999.043+svnr36882-r14.01_armv4t.opk>
> opkg install
> http://downloads.openmoko.org/repository/Om2008.8/armv4t/e-wm-theme-default_0.16.999.043+svnr36882-r14.01_armv4t.opk <http://downloads.openmoko.org/repository/Om2008.8/armv4t/e-wm-theme-default_0.16.999.043+svnr36882-r14.01_armv4t.opk>
> That second one is the 'real' fix to your original issue - it contains
> /usr/share/enlightenment/data/themes/default.edj.  I looked in my NAND (I
> usually run SHR from uSD but have 2008.12 on NAND) and sure enough there
> are illume.edj and asu.edj in that folder, no default.edj.  I can only
> assume that they'd reconfigured it to use asu.edj instead of default.edj,
> but that a newer e-wm requires default.edj again.
> But again, none of this answers why it's looking for a newer svn version of
> e-wm than is actually in the repository, which makes me suspect that a repo
> was added somehow that contains the svnr37988-r0.1...  It's not in 2008.8
> repo, testing, or unstable AFAICS.  So the steps I'd suggest are try
> manually installing the two packages noted above, then take a look in
> /etc/opkg and see what repositories are referenced, remove any
> inconsistencies, then try 'opkg update' and 'opkg upgrade'.
> j
> --
> Joel Newkirk
> http://jthinks.com <http://jthinks.com/>      (blog)
> http://newkirk.us/om <http://newkirk.us/om> (FR stuff)

Thanks for you quick reply.

What you wrote could indeed be true. I remember I tried installing
mplayer that day, which I didn't find in the repositories. But I did
find it in the angstorm repository. So I added this repository,
updated, installed mplayer and removed it (the repository). I've
checked and double-checked my current /etc/opkg files, and they seem
sane. Also compared with what is on the flash-image.

So, if this is the case, how do I make opkg "forget" what the no
longer included angstrom repository says about available packages? I
tried deleting /var/lib/opkg/*, 'opkg update' and both versions of
e-wm still show up on list.

I tried installing the package you suggested:
$ opkg install http://downloads.openmoko.org/repository/Om2008.8/armv4t/e-wm_0.16.999.043+svnr36882-r14.01_armv4t.opk
Downloading http://downloads.openmoko.org/repository/Om2008.8/armv4t/e-wm_0.16.999.043+svnr36882-r14.01_armv4t.opk
Multiple packages (e-wm and e-wm) providing same name marked HOLD or
PREFER.  Using latest.
Multiple packages (e-wm and e-wm) providing same name marked HOLD or
PREFER.  Using latest.
Installing e-wm (0.16.999.050+svnr37988-r0.1) to root...
Collected errors:
 * ERROR: Package e-wm (parent e-wm) is not available from any configured src.
 * Failed to download e-wm. Perhaps you need to run 'opkg update'?

but apparently opkg is smart enough to pick the newest version. Then I
tried downloading the file manually and run 'opkg install ./e-wm-0.16
....' with the same result. I looked at 'opkg --help' and tried some
options like -force-reinstall, -force-downgrade etc, but I couldn't
get opkg to install the package. So here I'm stuck again.

Any suggestions on how to proceed? Is there a way for actually force
opkg to install the package I want? Is there a way to manually install
the opk file, like unpacking it, moving the files to its' correct
locations and updating the opkg database files to include information
that the package is in fact installed? Any other options?

Thanks for your help.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.openmoko.org/pipermail/community/attachments/20081227/a072ca61/attachment.htm 

More information about the community mailing list