Navit language?

Fox Mulder Quakeman1 at
Sun Dec 28 01:12:48 CET 2008

"export LANG=de_DE" and "spd-say -l de '%s'" works for me to let navit
speak german. Don't know anymore why it didn't work at that time.
Just be sure to install a recent version because it works much better. :)


Michael Tansella wrote:
> I've got the same problem.
> Does anybody have an answer?
> Am Montag, 18. August 2008 13:38:15 schrieb Fox Mulder:
>> Hi everybody,
>> i want to change the default language in which navit speaks to german
>> but i don't find the necessary config for this. I use rev 1255 with map
>> move speed patch and everything (else) works fine. :)
>> Now i tried a simple "export LANG=de_DE" and started navit but this
>> seems to have no effect at all. I also installed the package
>> "navit-locale-de" for this purpose.
>> I see that in the source tree within the directory "po" all the language
>> files exist. I also changed the navit.xml entry for the speech engine to
>> "spd-say -l de '%s'" which pronounces the sentences the german way. But
>> the sentence strings still comes in english to the speech engine.
>> I tried to find the needed information in the navit wiki, but i only
>> found the needed changes to the speech entry in the navit.xml. But this
>> entry just changes the way the sentence is spoken, not the language
>> navit reports the sentences. :(
>> Can anybody say me where the option to change the language is?
>> Or must it be compiled with the wanted language and it can't be changed
>> afterwards?
>> Ciao,
>>      Rainer
>> _______________________________________________
>> Openmoko community mailing list
>> community at
> _______________________________________________
> Openmoko community mailing list
> community at

More information about the community mailing list