[2008.12] python-pygps unusable

Francesco de Virgilio fradeve11 at gmail.com
Tue Dec 30 18:25:01 CET 2008

Hi all,
first of all, thanks again for bring us 2008.12, I think it's the best
image of all times for my FR.

Today I've tried to set up a little script in python using the GPS and
installed from opkg the package "python-pygps". After that, opening a
python console, tried to import the "gps" module, and received an error
message (something about a "calendar module not present" or similar").

Now, I spet a _lot_ of time searching for solution, and googling I got
my answer: bug #2083[1].

This makes the gps bindings for python complete unusable on OM 2008.12,
until you install from opkg the package "python-datetime". I don't want
to spam, but I think that posting this on ML will prevent other people
from spending off time searching for a solution... :)


[1] https://docs.openmoko.org/trac/ticket/2083
Francesco de Virgilio
*Ubuntu-it Member and Wiki Editor*
   mailto:fradeve at ubuntu-it.org
*Wikimedia Italia Member*
*OpenStreetMap Mapper*
		"Love - Peace - Freedom - Free Software"

More information about the community mailing list