[Debian] Problem with qi and sd-card

Fox Mulder Quakeman1 at gmx.net
Tue Dec 30 21:20:08 CET 2008

xiangfu wrote:
> Hi
> Fox Mulder wrote:
>> Today i changed from u-boot to qi from [1] for my GTA02. I added /boot
>> to my rootfs and copied the kernel as uImage-GTA02.bin in it.
>> For my first try i added the append-GTA02 with "console=tty0 loglevel=8"
>> to see if it works.
>> After this worked very good to boot debian from my sd-card i removed the
>> append-GTA02 file to speed up the boot process a bit. But now i have two
>> lines of output which irritates me a bit.
>> -----
>> s3c2410_udc: debugfs dir creation failed -19
>> power_supply bat: driver faild to report 'status' properly
>> -----
>> After ~30 seconds X starts and everything goes on as expected.
>> Therefore i think this message is no problem, but i want to know if i
>> had made something wrong?
>> Also interesting is that the message says "s3c2410" even that i flashed
>> the "s3c2442" version for GTA02.
>> And another thing is that i don't know how to switch to nand booting
>> when powerup my freerunner. At the moment i only use debian from
>> sd-card, but for testing purpose i have 2008.12 installed on nand. But
>> now with qi i can't boot from nand as long as i have my sd-card put it.
>> I think i read somewhere that it is possible to skip a boot partition in
>> qi but i can't find it anymore. :/
>>From Qi README Line 107:
>  - You can disable a partition for boot by creating
> /boot/noboot-<devicename>,
>     eg, /boot/noboot-GTA02, it will skip it and check the next partition

That's right, but i don't want to disable the partition by a file just
to boot another partition. ;)
I want to do it on the fly while starting as described with the AUX
button. I only have to test it a bit further to get it to work with this


More information about the community mailing list