community Digest, Vol 68, Issue 16

Emre Turkay emreturkay at
Fri Feb 29 11:03:10 CET 2008

By the way, I don't have a debug board and I would prefer to not rewrite the
uboot. The uboot on the device is the one intalled by FIC before I got it.
It's from May.19.2007.

> From: Mike Montour <mail at>
> To: community at
> Date: Thu, 28 Feb 2008 19:24:34 -0800
> Subject: Re: Booting from SD
> Ortwin Regel wrote:
> > The problem might be your u-boot version. Try this one:
> >
> > It's what I've been using successfully. I never could get it to work
> > with other u-boot versions I tried.
> SD-booting in u-boot was broken for several months but as of late
> January it is fixed (or at least worked-around; the root cause of the
> bug has not yet been identified). The link you posted will boot from SD,
> but it has other bugs that have been fixed in later versions.
> Regarding the original problem, it is likely related to the 2.6.24
> kernel. The GTA01 SD-card driver was broken for a while. My
> understanding is that it is now functional, but that it is still
> configured to emit a large amount of debugging information. Things
> should work fine with a kernel as long as you have the
> corresponding modules installed on your root filesystem.
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the community mailing list