Power Management on Neo1973

Shawn Rutledge shawn.t.rutledge at gmail.com
Sun Jan 13 00:58:05 CET 2008

Now it's about 14 hours later and I'm seeing the same kind of numbers
from /sys/devices/platform/s3c2410-i2c/i2c-adapter/i2c-0/0-0008/chgcur:
800-1700.  I guess that means the battery is still not fully charged.

OK I'll reboot with the current probe installed and take some more measurements:

Initial poweron current is 280-290 mA, while the kernel messages are
scrolling by.  Then it goes up to 300-380 during the splash screen
period.  Near the end of the boot process it's 420 mA.  It didn't
finish booting because I need to do it through the boot menu, so I
power off.  It's now drawing 40mA while being turned off!  Disconnect
the battery, reconnect, and it's back to negligible current (0.12 mA
and falling) but now I cannot power it back on.  Plug in the USB and
it charges at 40mA.  Disconnect USB, I still cannot power it on.  OK
my Fluke has a resistance of 40 ohms in current mode, so that's why;
previous numbers are probably a bit low, because of the resistance,
and I will have to use an old analog meter.  With that one, on the
500mA range the total resistance across the current probe is 0.6 ohms,
that's more like it.

350mA at the boot prompt.  280-400mA while booting (fluctuates) with a
couple spikes to 500mA.  After booting it stays around 400mA mostly,
but I'm not running the UI yet and GSM should be off by default,
right?  I have to plug in USB so I can start up the UI, then unplug it
again... it goes to 500mA (and occasionally pegs the meter) then drops
back to 400mA after reaching steady state.  Battery meter applet shows
about 2/3 or so.  I select on the UI to power up GSM, and it doesn't
change the current much.  Select auto-register... OK it's going to
500mA more often.  Try to call the Neo from a land line... it's not
ringing or vibrating but current stays around 500mA until I hang up
the land line.  I verified using libgsmd-tool -m shell that GSM is
really on and connected and can receive calls.  Looks like the worst
case is 500mA but it doesn't stay there all the time.  Power off
GSM... it goes to maybe 360mA with some spikes to 400-something.  Try
to connect USB to turn off the backlight... it's misbehaving again.
UI is still up but not responding.  Current is steady at 420mA when I
disconnect USB.

I have not checked this old meter for how accurate it is.  It's a
Simpson 373.  Guess I'd better... OK Simpson in series with the Fluke,
plug in USB to make it boot, then remove USB, and because the boot
failed this time I got to a nice steady state of about 420mA discharge
current on the Simpson which reads 406mA on the Fluke.  Close enough.

I uploaded pictures of my measurement setup here:


and a video of the process here:


but at the moment it's still being processed by YouTube.  It is 20
megs and 4.5 minutes, and this is my first time using YouTube so we'll
see how long that takes.

On Jan 11, 2008 10:47 PM, Shawn Rutledge <shawn.t.rutledge at gmail.com> wrote:
> On Jan 10, 2008 2:57 PM, Shawn Rutledge <shawn.t.rutledge at gmail.com> wrote:
> > Yeah.  I wonder if the battery has deteriorated somehow (from the
> > phone running and being plugged in to USB for days or weeks at a time,
> > and being overcharged? but the power management chip should not
> > overcharge it, right?), or maybe it is not being fully charged.  I
> > consider it fully charged when it has been running, and plugged in to
> > USB, overnight.  I'm also wondering if my hub may be limiting it to
> > less than 500 mA though.  I need to measure the currents... both
> > battery current and USB current, in various states.
> Well I made a sort of "current probe" by gluing two pieces of very
> thin single-sided PCB material back-to-back (the result is thinner
> than any double-sided stuff I have at home).  I see -375mA (current
> coming out of the battery) as the usual load.  But when USB is plugged
> in, I see between -60 and -80 mA - current is still coming out of the
> battery.  So it's not getting charged; my hub must be limiting the
> current.  Let me plug in directly to my PC... OK now it's +25-+45mA,
> still fluctuating all over but charging the battery slowly.  I checked
> and it is in fast_cccv mode.  So I guess that means the USB current is
> probably 400mA or less... we have a load of 375mA plus some charge
> current is going into the battery, but the charge happens at a
> different voltage, but there is some loss in the charge circuit too.
> Now I unplug USB for a second and it goes to 450mA load current
> (coming out of the battery to run the phone).  OK 375 was lower than
> normal for some reason...
> So far that was running gllin, and logging data points, with the LCD
> and backlight on and showing the splash screen, but not running the
> UI.  Not sure if GSM is on in that state or not.  OK I will try it
> with a SIM installed, and running the UI...
> BTW current discharge is about 8-12 mA with the phone turned off.
> It's dropping a little over time.
> While the UI starts up the battery is still discharging.  Now that
> it's sitting at the main screen the current is about +35-+40mA,
> charging the battery.  Well it's not receiving a call.
> /sys/devices/platform/s3c2410-i2c/i2c-adapter/i2c-0/0-0008/chgcur
> fluctuates a lot too, from 693-2026 as I checked several times.  Tried
> unplugging USB again to see the load current (coming out of the
> battery when it's not charging); that is still 450mA.  But when I plug
> it back in, USB is misbehaving:
> usb 2-1.1: khubd timed out on ep0in len=0/64
> usb 2-1.1: khubd timed out on ep0in len=0/64
> usb 2-1.1: device descriptor read/64, error -110
> usb 2-1.1: khubd timed out on ep0in len=0/64
> and the battery current is -350mA (because it's taking 100mA from USB
> by default, right).

More information about the community mailing list