OpenMoko on hx4700

Sébastien Lorquet squalyl at
Fri Jan 18 11:58:09 CET 2008

Hi all,

I managed to build OpenMoko with MokoMakefile for hx4700 (make setup, change
machine to hx4700 in local.conf, make openmoko-devel-image, all went fine).
Then I tried to run it.
I lauched the kernel with haret, and booted from an ext2 256 MB SD card (a
rootdelay option is needed on the kernel command line)

So, this gives me a wince-openmoko dual boot :)

With the 624 MHz pxa270, the speed is fine, kinetic scolling works like a
charm, and the whole UI is very reactive :)


The problem is, hx4700 has no GSM modem, while openmoko keeps searching for
a network.
So I get a full list of status messages at the bottom of the window, that
are very annoying. Do you have any idea to remove them? I tried to stop
/etc/init.d/gsmd, but it's not running. I guess I have to stop a gsm status
applet, but I don't know how to do this.
Here is an example: : "Not searching"
blocks displayed at the bottom of the screen.

Do you have any idea on how to map the hx4700 power button to the openmoko
shutdown/suspend command, so that I can save battery life? I'll ask
questions on the handhelds-hx4700-port mailing list too, but I need to know
how buttons are managed in OM before I ask them how to achieve this !

Ah, last problem (and a minor one), at boot up I see on the fb console that
some jffs2 mount operation is not happy with my flash (of course, it's full
of wince and not jffs2 :) ) . I guess this is an init script trying to mount
some inexistent partition. Can I disable this?
Here is the "screenshoot":
Cowardly refusing to erase blocks... fine, I didn't loose my wince image :D


Sébastien LORQUET
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the community mailing list