OpenMoko on hx4700

pHilipp Zabel philipp.zabel at
Fri Jan 18 12:20:04 CET 2008

Hi Sébastien,

On Jan 18, 2008 11:58 AM, Sébastien Lorquet <squalyl at> wrote:
> Hi all,
> I managed to build OpenMoko with MokoMakefile for hx4700 (make setup, change
> machine to hx4700 in local.conf, make openmoko-devel-image, all went fine).
> Then I tried to run it.
> I lauched the kernel with haret, and booted from an ext2 256 MB SD card (a
> rootdelay option is needed on the kernel command line)
> So, this gives me a wince-openmoko dual boot :)
> With the 624 MHz pxa270, the speed is fine, kinetic scolling works like a
> charm, and the whole UI is very reactive :)


> but...
> The problem is, hx4700 has no GSM modem, while openmoko keeps searching for
> a network.

I think it is the openmoko-dialer2 doing that.

> So I get a full list of status messages at the bottom of the window, that
> are very annoying. Do you have any idea to remove them? I tried to stop
> /etc/init.d/gsmd, but it's not running. I guess I have to stop a gsm status
> applet, but I don't know how to do this.
> Here is an example: : "Not searching"
> blocks displayed at the bottom of the screen.
> Do you have any idea on how to map the hx4700 power button to the openmoko
> shutdown/suspend command, so that I can save battery life? I'll ask
> questions on the handhelds-hx4700-port mailing list too, but I need to know
> how buttons are managed in OM before I ask them how to achieve this !

Doesn't it work when you press the power button for a long time?
OpenEmbedded already had a patch to neod to do that:
and since revision 3348 it is contained in upstream neod.

> Ah, last problem (and a minor one), at boot up I see on the fb console that
> some jffs2 mount operation is not happy with my flash (of course, it's full
> of wince and not jffs2 :) ) . I guess this is an init script trying to mount
> some inexistent partition. Can I disable this?
> Here is the "screenshoot":
> Cowardly refusing to erase blocks... fine, I didn't loose my wince image :D

Try removing the line containing jffs2 from /etc/fstab.


More information about the community mailing list