Openmoko Webshop Reopen NOW!!!

Michael T. Dean mtdean at
Sat Jul 5 06:05:01 CEST 2008

On 07/04/2008 09:42 PM, Joachim Steiger wrote:
> Michael T. Dean wrote:
>> On 07/03/2008 02:55 PM, Michael T. Dean wrote:
>>> I'm getting a Gateway Error 
>>> 500" before I even get a chance to enter my credit card info--i.e. when 
>>> it says, "Forwarding you to Hi_Trust..."
>>> Full text of the message is: "Error from the Hi Trust gateway: TrustLink 
>>> Server is closed. Or Merchant Server IP is not consistent with TrustLink 
>>> Server setting."
>> Seems this one has something to do with my NAT'ing firewall/router.  
>> When I tried from a computer with a direct connection to the Internet, 
>> it went through without a problem.  I tried all combinations of Firefox 
>> 2, Internet Explorer, and Firefox 3 and the only difference in the 
>> systems was the network connection (and the fact that the one that 
>> worked--with the direct connection--was running Windows, but I'm pretty 
>> sure that's not the issue).
> i can assure you that this is not the case.
> in all cases we had this error it was the sending bank blocking the
> transaction till the card was activated for international billing or
> some similar automatic protection mechanism.

Which could /not/ happen before I've been given a chance to type in my 
credit card information--i.e. before they know which card/bank to ask 
for authorization.

BTW, this is 100% repeatable (even still) on any computer on my network.


More information about the community mailing list