dfu-util upload problems

Thomas B. tommy.b at gmx.net
Sun Jul 6 18:26:22 CEST 2008


I have a little problem with dfu-util and my new Freerunner.

I thought I'd make a backup of my Neo's filesystem before flashing new
images onto it, so I tried to use dfu-util in upload mode to transfer
the content of the Neo's flash to my desktop PC. Backing up the kernel
partition works, but when I back up the rootfs partition dfu-util
transfers about 247MB and then dies with "dfu_upload error -84", while
the phone immediately reboots. It always dies at the same position, but
I'm not sure whether the backup is complete or not.

Further details: I've tried it on my desktop and on my laptop PC, with
Ubuntu 7.10, Ubuntu 8.04 and a grml live-cd, with various dfu-util
binaries and one built from SVN, but the error appeared every time. The
phone was hooked up directly to the host (no hub or something), U-Boot
version on the phone is the originally installed 1.3.2-moko12 from May

Any ideas what's wrong?


More information about the community mailing list