Fast questions (email, GPRS, WiFi...)

Russell Sears sears at
Sat Jul 12 02:50:37 CEST 2008

I do this:

ifdown eth0
iwconfig eth0 essid "TheEssid" && ifup eth0 && ifdown usb0

I haven't setup wpa or even wep though...

- What does iwconfig say before you do udhcpc?  Did the card associate 
with the access point (non-zero link quality)?  Did the card discover 
the access points MAC address?

- What does "ifconfig -a" say after udhcpc?  "route -n"?


Jim Morris wrote:
> ian douglas wrote:
>> I havne't seen any wifi UI applicaiton yet. I SSH'd into my Freerunner,
>> edited /etc/wpa_supplicant/wpa_supplicant.conf to alter the essid and
>> key, typed "ifup eth0", then unplugged the USB cable, opened a terminal,
>> ran "ifconfig usb0 down", opened the browser and navigated just fine.
> I've been trying for several hours to get wifi working, it never seems to connect although it can 
> see my station.
> I tried this too as it makes sense to turn off usb0, but that didn't seem to work either, I wrote 
> this script to make it easy from console (I also tried ifconfig usb0 down)
> ifdown usb0
> wpa_supplicant -ieth0 -c/etc/wpa_supplicant/wpa_supplicant.conf -B
> sleep 10
> udhcpc eth0 &
> Any other ideas?
> Thanks

More information about the community mailing list