Web Browser Zoom?

Al Johnson openmoko at mazikeen.demon.co.uk
Sat Jul 12 18:50:35 CEST 2008

On Saturday 12 July 2008, Michael Kluge wrote:
> Al Johnson schrieb:
> > On Saturday 12 July 2008, Michael Kluge wrote:
> >> Brian C schrieb:
> >>> I can't figure out how to zoom in/out while using the web browser
> >>> (and/or change the font size).  Is this functionality not yet coded or
> >>> am I missing something?  Right now the fonts are too big and I see far
> >>> too little of the page for it to be really usable.
> >>>
> >>> Brian
> >>
> >> Hi Brian,
> >>
> >> try to compile and install Minimo. It has zoom (but never hides the
> >> keyboard).
> >
> > I've tried that using mokomakefile:
> > 	make build-package-minimo
> > It always fails during config.  Any idea what I'm doing wrong?
> No. How should I without an error message ;)

I know ;-) I would have posted it, but was in the middle of another build. 
That's finished now so I've tried again with the same result - see below.

> Do you have the toolchain 
> installed? I usually do
> . setup-env
> cd build
> bitbake minimo
> That works if 'make openmoko-devel-image' did not fail (usually it does
> not). Then you have an ipk somewhere. Just copy it over (as well as the
> lib that is beeing build as depency). And do an opkg install ...
> I think I could also put my two ipk files somewhere.

I get exactly the same result doing that as 'make build-package-minimo' - 
error below. The toolchain is fine I think. I am running an image I built, 
and have built individual packages including dillo and the matchbox keyboard. 
Those work fine, and I have repo configs so opkg can pull the deps in over 
the network. I tried a clean build, but got the same result again.

ERROR: function do_compile failed
ERROR: log data follows 
| NOTE: make -j 4 -f client.mk build
| make
| make[1]: Entering directory 
| make[1]: warning: jobserver unavailable: using -j1.  Add `+' to parent make 
| rm -f -rf ./dist/sdk
| rm -f -rf ./dist/include
| /usr/bin/make -C config export
| make[2]: Entering directory 
| /home/moko/build/tmp/staging/x86_64-linux/usr/bin/perl -I. ./bdate.pl 
| /home/moko/build/tmp/work/armv4t-angstrom-linux-gnueabi/minimo-1_0.02+cvs20070626-r0/mozilla/config/nsinstall -R -m 
644 nsBuildID.h ../mozilla-config.h ./nsStaticComponents.h  ../dist/include
rm -f ../config/final-link-comps ../config/final-link-libs ../config/final-link-comp-names
| rm -f ../dist/bin/chrome/chromelist.txt
| /home/moko/build/tmp/work/armv4t-angstrom-linux-gnueabi/minimo-1_0.02+cvs20070626-r0/mozilla/config/nsinstall -t -m 
nsBuildID.h ../mozilla-config.h ./nsStaticComponents.h  ../dist/sdk/include
| /home/moko/build/tmp/work/armv4t-angstrom-linux-gnueabi/minimo-1_0.02+cvs20070626-r0/mozilla/config/nsinstall: 
cannot access nsBuildID.h: Invalid argument
| make[2]: *** [export] Error 1
| make[2]: Leaving directory 
| make[1]: *** [default] Error 2
| make[1]: Leaving directory 
| make: *** [build] Error 2
| FATAL: oe_runmake failed
NOTE: Task 
failed: /home/moko/build/tmp/work/armv4t-angstrom-linux-gnueabi/minimo-1_0.02+cvs20070626-r0/temp/log.do_compile.6690
NOTE: package minimo-1_0.02+cvs20070626-r0: task do_compile: failed

More information about the community mailing list