Fast questions (email, GPRS, WiFi...)

Jim Morris ml at
Sun Jul 13 00:31:50 CEST 2008

Russell Sears wrote:
> I do this:
> ifdown eth0
> iwconfig eth0 essid "TheEssid" && ifup eth0 && ifdown usb0
> I haven't setup wpa or even wep though...
> - What does iwconfig say before you do udhcpc?  Did the card associate 
> with the access point (non-zero link quality)?  Did the card discover 
> the access points MAC address?
> - What does "ifconfig -a" say after udhcpc?  "route -n"?

 > iwlist scanning
eth0      Scan completed :
           Cell 01 - Address: 00:1D:5A:BB:FA:A9
                     Frequency:2.422 GHz (Channel 3)
                     Quality=45/94  Signal level=-50 dBm  Noise level=-95 dBm
                     Encryption key:on

So it sees my AP, I do have ESSID broadcast turned off, I'll try with it on in a sec.

 > iwconfig
eth0      AR6000 802.11g  ESSID:""
           Mode:Managed  Bit Rate=1 Mb/s   Tx-Power=0 dBm   Sensitivity=0/3
           Encryption key:off
           Power Management:on
           Link Quality:0/94  Signal level:-95 dBm  Noise level:-96 dBm
           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
           Tx excessive retries:0  Invalid misc:0   Missed beacon:0

So its not connected

 > ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:12:CF:74:20:A8
           UP BROADCAST MULTICAST  MTU:1500  Metric:1
           RX packets:324 errors:0 dropped:0 overruns:0 frame:0
           TX packets:156 errors:0 dropped:0 overruns:0 carrier:0
           collisions:0 txqueuelen:1000
           RX bytes:150058 (146.5 KiB)  TX bytes:7223 (7.0 KiB)

eth0:avah Link encap:Ethernet  HWaddr 00:12:CF:74:20:A8
           inet addr:  Bcast:  Mask:
           UP BROADCAST MULTICAST  MTU:1500  Metric:1

 > netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface   U         0 0          0 usb0     U         0 0          0 eth0         UG        0 0          0 usb0

(I have not disabled usb0 at this point)

Should I use iwconfig or ifconfig to setup eth0, its not clear?
I am currently doing exactly what it says on the GTA02 wlan wiki page.

 > udhcpc eth0

just scans indefinately Although that may be becuase eth0 needs to be disabled. but right now it 
obviously is not connected to the AP.

More information about the community mailing list