sshd dropbear segmentation fault errors

Ben ben at
Sun Jul 13 04:24:36 CEST 2008

Le Sat, 12 Jul 2008 21:08:53 +0200,
Michael Münch <micm at> a écrit :

> I am writing a small script to automate some tasks on the freerunner.
> For that I use the 'ssh root at "command"' syntax. When
> using "more complicated" commands like opkg upgrade I get a
> segmentation fault error. After I exchange dropbear with openssh it
> works.
> Will there be a change from dropbear to openssh in some images apart
> from 2007.2 or is there any chance to "repair" dropbear?
> At the moment I dont know where start to solve this issue.
> Michael

I had the same problem with dropbear; so I wasn't able to make an
correct upgrade.
Then, I've used screen, and made the upgrade in there. screen -x after
the problem with dropbear and all's fine.
screen accept commands and arguments

More information about the community mailing list