[qtopia on freerunner] - What files do I have to download?

Thomas B. tommy.b at gmx.net
Sun Jul 13 21:02:01 CEST 2008


On Sun, Jul 13, 2008 at 04:40:09AM +0200, Cédric Berger wrote:
> I would like to boot Qtopia from SD, but couldn't yet...
> Can I do that with the image of Qtopia you mentioned ?
> I extracted the files form the .jffs2 and copied them on the microSD card.
> I then put the uImage bin in /boot

You have to put uImage.bin in a FAT partition... at least that's how
it's supposed to be when you use the default U-Boot environment. See


> I tried with SD card formated in ext3 and ext2.

It seems you have to use ext3 for the rootfs partition, because current
kernel builds have ext2 support only as a module (which is not yet
available before the rootfs is mounted).

Then I had the following problem: U-Boot told the kernel that the rootfs
was ext2, even if it was ext3, so the kernel couldn't mount it. I solved
that by logging in to the U-Boot console via USB and modifying the
command sequence to boot from SD so that it looks like this (I just
replaced ext2 with ext3):

menu_1=Boot from microSD (FAT+ext3): setenv bootargs ${bootargs_base} rootfstype=ext3 root=/dev/mmcblk0p2 rootdelay=5 ${mtdparts} ro; mmcinit; fatload mmc 1 0x32000000 ${sd_image_name}; bootm 0x32000000

Here you can also see that it expects the kernel to be on a FAT
partition (it uses the command "fatload"). Maybe that could be changed,
so that it reads the kernel from the ext2 or ext3 partition itself, but
I don't know which commands U-Boot supports.


More information about the community mailing list