C R McClenaghan chris at
Mon Jul 14 23:28:48 CEST 2008

Here are my results of pumping NMEA data from the FreeRunner to  
another GPS client and pumping NMEA data from another GPS device to  
the Freerunner.

FR -> GPSy (Mac OS X client)  - could not get a fix on NMEA data
Garmin 10 -> FR - tangoGPS worked flawlessly

Apparently, agpsui reads directly from /dev/ttySAC1 even when gpsd is  
running. Couldn't get agpsui to "see" the Garmin 10 data. Also, GPSy  
worked flawlessly with Garmin 10 data.

As near as I can tell, the two data streams are very different in  
terms of GPS data and information. I'm not knowledgeable enough to say  
what the difference is, except the FR data is much more terse/brief  
(shorter length of each line of data).

What this experiment tells me is that data coming from the FR GPS chip  
either directly or via gpsd is does not contain enough information for  
a fix. What software exists between gpsd and/or /dev/ttySAC, if any,  
may be responsile or the GSP chip itself is not getting what it needs  
from the antenna.


More information about the community mailing list