[qtopia on freerunner] - What files do I have to download?

Jim Morris ml at e4net.com
Tue Jul 15 03:07:40 CEST 2008

Thomas B. wrote:

> Then I had the following problem: U-Boot told the kernel that the rootfs
> was ext2, even if it was ext3, so the kernel couldn't mount it. I solved
> that by logging in to the U-Boot console via USB and modifying the
> command sequence to boot from SD so that it looks like this (I just
> replaced ext2 with ext3):
> menu_1=Boot from microSD (FAT+ext3): setenv bootargs ${bootargs_base} rootfstype=ext3 root=/dev/mmcblk0p2 rootdelay=5 ${mtdparts} ro; mmcinit; fatload mmc 1 0x32000000 ${sd_image_name}; bootm 0x32000000

I am having similar problems with latest FR. I have tried ext2 and ext3 root, still get a kernel 
panic because it can't mount root.

Can you explain exactly how you used the usb console to change the boot? what runs on the host 
computer that lets you access the USB console? (Is it a standard serial terminal talking to a 
usd/serial emulator?)


Jim Morris, http://blog.wolfman.com

More information about the community mailing list