Toolchain and missing libraries

Joachim Breitner mail at
Tue Jul 15 11:47:03 CEST 2008


Am Montag, den 14.07.2008, 21:11 -0700 schrieb Jim Morris:
> Ok good luck with toolchain, I tried and found a bunch of libs were missing... I'll try again later.

You can get opkg to work in the toolchain to install missing libs. The
steps were roughly:

$ wget

„Install“ it:
$ dpkg -X opkg-sdk_0.1.4+svnr4491-r1_i686-armv4t-sdk.ipk /

Do some hackish workaround
$ mkdir /usr/local/openmoko/arm/arm-angstrom-linux-gnueabi//opkg/opkg -p

Fix the feed file:
$ cat /usr/local/openmoko/arm/arm-angstrom-linux-gnueabi/etc/opkg.conf 
src oe
arch all 1
src oe-all
arch any 6
arch noarch 11
arch arm 16
arch armv4t 21
src oe-armv4t
arch neo1973 31
src oe-neo1973
arch om-gta02 36
src oe-om-gta02

Install what you need 
$ . /usr/local/openmoko/arm/setup-env
$ opkg-target install libjana-dev

Then I could successfully use om-conf and om-make-ipkg for packages like
openmoko-messages2, as found in SVN.

I had a problem with the newest gtk files, for some reason libtool tried
to link them form /usr/lib/ instead those found in /usr/local/openmoko.
My work around was:
$ sed -i 's/installed=yes/installed=no/' /usr/local/openmoko/arm/arm-angstrom-linux-gnueabi/usr/lib/*la

Maybe this is all very wrong and I’m just lucky that it worked, in this
case, please correct me.


Joachim Breitner
  e-Mail: mail at
  ICQ#: 74513189
  Jabber-ID: nomeata at
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: Dies ist ein digital signierter Nachrichtenteil
Url : 

More information about the community mailing list