Reason for GPS problems found!

nick loeve trickie at
Thu Jul 17 10:55:26 CEST 2008

Hi again,

On Wed, Jul 16, 2008 at 5:26 PM, nick loeve <trickie at> wrote:
> Hi Andy (nice work BTW, you and the rest of the team)
> On Wed, Jul 16, 2008 at 5:02 PM, Andy Green <andy at> wrote:
>> Hash: SHA1
>> Somebody in the thread at some point said:
>> | FWIW i just flashed
>> |
>> | today and i got a fix outside with my sd card inserted. Previously i
>> | never saw a satellite unless i took it out.
>> |
>> | Did that build have the patches i see at
>> |;a=shortlog;h=andy ?
>> Those guys are built off "stable" branch going by the git hash, it
>> doesn't have the latest patches in yet that are in "andy".
>> The only GPS-related patch it should have is one that stops power from
>> idle / high UART TX pin leaking into GPS section when it is 'off', but
>> that isn't directly suspected.
>> So I dunno why your GPS is all happy after being happy the first time,
>> but long may it last :-)
> Yeah this is nice, but strange... as I have tried for more than the
> last week to even see a satellite, in a range of conditions, and
> positions, and sometimes for hours at a time.
> Oh well, not complaining... :)

I just tried the latest mwebster-andy kernel from which has the sdcard clock
patches, and now i get even better signals, and fix from cold start
outside in 48secs.

So the voltage patch certainly helped, and the sdcard clock patches
seemed to have made it even better.

I have not tried accessing maps from sdcard while using GPS, but i
will try and test that later.

Cheers, and thanks for the good work!

>> - -Andy
>> Version: GnuPG v1.4.9 (GNU/Linux)
>> Comment: Using GnuPG with Fedora -
>> eHQAoIMo2QqfNztz5QW7aZ9MuXy74Um7
>> =Sxhi
>> -----END PGP SIGNATURE-----
>> _______________________________________________
>> Openmoko community mailing list
>> community at
> --
> Nick Loeve

Nick Loeve

More information about the community mailing list