Reason for GPS problems found!

Russell Sears sears at
Thu Jul 17 17:46:17 CEST 2008

I did an opkg update on the factory image last night (~7-8 PM PST), and 
now GPS fix times are less than a minute.  The update downloaded a new 

# opkg status kernel
Package: kernel
Version: 2:2.6.24+git20+287b292cf95edbd82dc63085ae5f0167a6e8141f-r0
Depends: kernel-2.6.24
Status: install user installed
Architecture: om-gta02

Did I get the SD patch or not?  I ask because I'm updating the wiki, and 
don't want to put wrong information up...  For what it's worth, my 
initial test suggests that playing .ogg files off SD doesn't seem to 
affect getting a GPS fix...


Andy Green wrote:
> Hash: SHA1
> Somebody in the thread at some point said:
> | 2008/7/17 nick loeve <trickie at>:
> |> I just tried the latest mwebster-andy kernel from
> |> which has the sdcard clock
> |> patches, and now i get even better signals, and fix from cold start
> |> outside in 48secs.
> |>
> |> So the voltage patch certainly helped, and the sdcard clock patches
> |> seemed to have made it even better.
> |
> | I tried the kernel too, but it didn't help. Didn't get any fixes in 3
> | minutes when having SD card in (not in use, ie. maps not there).
> | Removed the SD card and got a TTFF in 34 seconds.
> Two points about testing it:
> ~ - order of tests can matter.  If you get a "good" test first, it seems
> the requirements for next test can be relaxed by GPS chip and we don't
> really test it then.
> ~ - patch only helps if SD Card is not accessed.  I read a thread
> yesterday in devel list about some ASU / Qtopia component spamming SD
> Card after start up.
> - -Andy
> Version: GnuPG v1.4.9 (GNU/Linux)
> Comment: Using GnuPG with Fedora -
> iEYEARECAAYFAkh/KnoACgkQOjLpvpq7dMp7XgCeIaswI/HWS2Skls5m2vkBUpGp
> ugsAn3+mrJWRLzxG4sSBQBwzlRQMhQ7d
> =o/l6
> _______________________________________________
> Openmoko community mailing list
> community at

More information about the community mailing list