Operation without battery (GTA02)

Andy Green andy at openmoko.com
Thu Jul 17 23:19:13 CEST 2008

Hash: SHA1

Somebody in the thread at some point said:
| On Thu, 17 Jul 2008 22:07:51 +0200, Andy Green <andy at openmoko.com> wrote:
|>>> Probably GSM trying to pull ~2A for transmitting.
|>>> This will make the device shut down instantly.
|>>> Try disabling GSM!
|>> Turning GSM off from the power menu didn't help.
|>> Besides, I don't even have a SIM card inserted.
|> This seems to be to do with the PMU charger deciding to start charging
|> empty air making trouble.  The charger is autonomous and runs by itself
|> on its own schedule.  Maybe we can find a way to defeat this behaviour,
|> but for now you need a battery in to boot and to stay running.
| Did it work and then regress, or has it never worked? I remember
people on
| the list mentioning running without a battery.

I ran without a battery for many weeks earlier in the year.  It seems to
be specifically if we enable the PMU charger with no battery, it freaks
out and goes to PMU STANDBY state.  Earlier in the year, we didn't
enable charger yet so it hangs together.

| However, running without a battery isn't really a use case. While
| in, the phone can survive without a battery for several seconds, which
| enough to quickly insert a spare.

Well it can be a use case if you don't want GSM... as Joerg said USB
alone cannot provide enough power for GSM TX usage so there's no hope
for it (or any other GSM device) being an actual phone with no battery.
~ But it's actually a pretty decent embedded / server / smart display
device aside from the phone aspect useful for other things if it can be
tethered to some always on power without battery, so I still hope that
can be gotten to work.

- -Andy
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org


More information about the community mailing list