[qtopia on freerunner] - What files do I have to download?

Cédric Berger cedric.berger74 at gmail.com
Fri Jul 18 01:21:23 CEST 2008

I used this method to boot qtopia from sd.

And now I have tri-boot : I added a 3rd partition on microSD for ASU
and I changed u-boot menu with menu_2 almost identical to menu_1,
except root=/dev/mmcblk0p3
(I use the same kernel partition on FAT for both qtopia and ASU.
Though at first I used 2 different uImage, in the same partition )

Anyway... when booting this way on microSD....
How do you "opkg upgrade" ?
-> it wants to update kernel on internal flash, which fails and
prevents opkg to success :
" process /usr/bin/flash_eraseall: /dev/: Is a directory postinst
script returned status 1 Nothing to be done Collected errors: ERROR:
kernel-image-2.6.24.postinst returned 1 "

(I found this : http://docs.openmoko.org/trac/ticket/1344 )

-> I tried to modify the U-Boot command on menu :
instead of
 ${mtdparts} ro

and then it "worked" : opkg could write kernel (but with warnings...)
and could finish upgrade.

Not clean though ! It shouldn't have to modify internal memory (kernel
of other distribution !)

How could we do to prevent it ?
 Is it the postinst script that must be modified ? Or can we tweak the
U-Boot command to have it write elsewhere ?
Is it possible to do a opkg upgrade  but telling it not to upgrade
kernel ? (and do it manually...)

More information about the community mailing list