Reason for GPS problems found!

Timo Jyrinki timo.jyrinki at
Sat Jul 19 17:02:49 CEST 2008

2008/7/19 Roland Mas <lolando at>:
>> Does anyone else have a reliability problem now with the new kernel
>> and GPS when SD card is used?
> *Apparently*, there are
> circumstances where running agpsgui once, getting a fix, exiting and
> restarting afterwards, doesn't result in the FR getting a new fix.  As
> you said, rebooting solves the problem, but suspend/resume cycles
> don't seem to reliably fix it.

Yep, I now had an opportunity to test it more. I used mostly TangoGPS,
and it seemed that in real world I basically needed to reboot every
time I wanted to reliably have a GPS fix. It felt like (just guesses,
hard to really isolate what's going on) if the device had suspended
even once, or otherwise stood still, I got zero satellite visibility
(also checked in AGPS UI). Even worse, it seemed that often after
reboot I first got satellite visibility for 30-60s, but before getting
a fix the satellites were lost again. But when it worked for long
enough, I got proper fixes with 6-10 satellites and the fix stayed,
which is of course way better than before the kernel fix, when this
was never possible.

The problem getting even the first fix after reboot might be related
to loading the initial map files from SD card, thus perhaps activating
the SD.

I haven't at least yet tried the tip about blinking led when SD clock
is active, but that might indeed be a very good debugging method for


More information about the community mailing list