Rogers SIM (Canada) causing crash on Dialer

Sparrow sparrow at
Sat Jul 19 23:38:14 CEST 2008

Hi Christopher, 

	I think my phone has registered with my provider, just not letting me
dial out.  From running "libgsmd-tool -m shell" here is what I am

libgsm-tool - (C) 2006-2007 by Harald Welte and OpenMoko, Inc.
This program is Free Software and has ABSOLUTELY NO WARRANTY

# Read current opername
Our current operator is Rogers Wireless
# Query network registration
registered (home network) 
EVENT: Signal Quality: 28
# Unknown command `416XXXXXXX'
# Dial 416XXXXXXX
EVENT: Outgoing Call Progress: UNKNOWN
EVENT: Outgoing Call Progress: REJECT
EVENT: Outgoing Call Progress: RELEASE
EVENT: Signal Quality: 25

In the above, I have replaced the part of the number dialled with X's. 

Best Regards, 
Steven O'Reilly

On Sat, 2008-07-19 at 17:17 -0400, Christopher White wrote:
> On Sat, 2008-07-19 at 17:05 -0400, Sparrow wrote:
> > I have an issue with a rogers (Canada) SIM card crashing the
> > dialer application when a call is started.  After hitting "dial" on the
> > dialer app the screen moves cuts over to the out going call screen and
> > then the dial crashes. 
> I have seen exactly the same issue with an AT&T SIM that fails to
> register with the network (stays at "Registering..." and libgsm-tool
> shows registration denied).  Swapped to a T-Mobile SIM and finally I can
> dial out.
> I too would be interested in knowing where to start debugging this.
> Having a hard time finding a good point to grab on to.  I see no log
> messages in logread and difficult to find anything on the wiki regarding
> debugging.  Any good wiki pages about this?
> ...cj
> _______________________________________________
> Openmoko community mailing list
> community at

More information about the community mailing list