USB Host Mode for Wifi Card - help!

Seattle Web Creations, LLC info at
Sun Jul 20 00:04:27 CEST 2008

I¹m having a problem getting my Linksys WUSB54GC  USB wifi card recognized
on the FR. I purchased a mini-USB to USB adapter as found here:

Also, I¹ve picked up a battery powered USB hub like this one:

My Debian Sid installation boots from microSD with a kernel built with the
rt2x00 and rt73usb drivers (the same ones that are included with the kernel); I have copied the rt73 firmware to /lib/firmware/
as well.

When I boot the Neo, I execute the command: echo 1 >

Once I run the above command viola ­ my powered USB comes to life (although
there is also a light that comes on to inform me that the Freerunner is
charging it... Which seems to somewhat defeat the purpose of a powered USB
hub a little :>/

I can plug in my SD card reader and it gets powered ­my WUSB54GC doesn¹t
seem to get enough power, nor is recognized by the FR after I modprobe
rt73usb and try ifconfig rausb0 up (I¹ve tried rasub1, wlan0, wlan1,
wmaster0 also).

Does anyone have any idea of what the problem can be? I would greatly
appreciate you help to find out if USB host mode will support wireless

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the community mailing list