Problems with building openmoko-sample with toolchain

Andreas Dalsgaard andreas.dalsgaard at
Tue Jul 22 10:06:02 CEST 2008

2008/7/22 Dylan Reilly <dreilly at>:
>> Haven't been able to get the patch to work, I had to modify it to use the
>> right paths, but then all hunks fail still.
>> Why isn't the toolchain in a working state? How is anyone doing development?
>> I've been playing around with it but I still can't get the sample project to
>> compile.
> I am also having difficulties. I made a valiant effort to replace all
> the erroneous
> references in all the .la files in
> /usr/local/openmoko/arm/arm-angstrom-linux-gnueabi/usr/lib
> but that sort of thing rarely goes well when one is not familiar with
> the system.
> Are there any tool chains available with correct references, a fixed patch for
> the current one, or etc.? I have some ideas I really want to start hacking out.

I have been working on an Ubuntu package of the toolchain. I'm
currently testing it but if anyone want to help out take a look at:

At the moment the package fixes the .la problem with an "evil hack"
that make the compilation process use an alternative libtool script.
Actually I would like to have ./configure pick up the LIBTOOL
enviroment variable instead but I have not figured that part out yet,
however I believe this might require another autoconf package.

> --
> Dylan Maxwell Reilly
> _______________________________________________
> Openmoko community mailing list
> community at

More information about the community mailing list