[Qtopia] roaming - manual selection not working

Cédric Berger cedric.berger74 at gmail.com
Wed Jul 23 16:44:32 CEST 2008

I confirm also that if from the UI  I try to select a network from
available gsm networks, it asks me if I want to switch to manual and
fails :

log shows a failed :
But manually I was able to do it by :

=> looks like the quotes where missing in command issued by Qtopia
(if I omit them I have the same error message)

And still there is the error when directly selecting the Change Mode
in menu, from Automatic to Manual :
AT+COPS=1,2,0    fails

=>provider number is missing ("20810")    (or is "0" meaningful for
current provider? if so maybe it is only the quotes missing...)

On Tue, Jul 22, 2008 at 23:34, Cédric Berger <cedric.berger74 at gmail.com> wrote:
> not so easy to try since at home I do not have access to roaming network...
> but when I try to select manual search mode (while yet connected) from
> the Network selection menu, which fails, log shows :
> AT+COPS=1,2,0
> so it looks like the AT+COPS=1,2,0 is wrong : last number should have
> been provider number (20810)
> I was able from console to do a successful AT+COPS=1,1,"SFR"   (and I
> think also AT+COPS=1,2,"20810")
> (when connected to roaming network,I thought I had seen failed log of
> AT+COPS=1,2,20810  but I will have try again tomorrow....)
> On Tue, Jul 15, 2008 at 09:09, Cédric Berger <cedric.berger74 at gmail.com> wrote:
>> Hi,
>> My freerunner connects to my operator with no problems (SFR, france),
>> and when I am in switzerland (geneva) and loose the signal, it
>> automatically switches to another (swisscom... roaming costs so much
>> more expensive for me...). That's fine with automatic mode.
>> But I cannot force it into manual mode (once it has switched, even
>> though the SFR signal is back -and even if it is stronger than
>> swisscom's-, it won't try to go back to SFR).
>> Even rebooting, it stays on the same network.
>> When I try in the settings-Call Networks  to "Select operator", it
>> fails ("Failed to register to the selected network operator").
>> Same error when I just try to switch mode from Automatic to Manual, on
>> either of these 2 networks.
>> Any idea ? Does this work for some people ?
>> I guess I should try in console with AT commands...
>> (I could only force switch back by putting my SIM in my old phone,
>> switching network, and SIM back into freerunner ! )

More information about the community mailing list