Problem upgrading ncurses

Alex Fitzpatrick alex.fitzpatrick at
Thu Jul 24 03:29:18 CEST 2008

Dale Schumacher wrote:
> On Wed, Jul 23, 2008 at 6:54 PM, Stroller 
> <stroller at 
> <mailto:stroller at>> wrote:
>     There's a bug in TRAC for this:
>     The fix there went from "in testing" to bug "closed" in the last
>     couple of days, so presumably it works. Please confirm.
> This is exactly the problem.  I applied the recommended fix:
> opkg -force-depends remove libncurses5
> opkg install ncurses libncurses5
> Now everything seems to be up-to-date.  Thanks!
> Should this be in the wiki somewhere, or will new users not have this 
> problem if they update/upgrade directly from the factory image?
opkg update, opkg upgrade still results in the same error

But the forced remove above resolves it for me also, a subseqent update, 
upgrade gives no errors.

It needs to go somewhere, anyone upgrading actory-installed 2007.2 image 
without re-flashing will hit this error message until the forced remove 
is done.

Alex Fitzpatrick
Gatineau, Quebec

More information about the community mailing list