Upgrading issue: kernel-module-ext2

Andy Green andy at openmoko.com
Thu Jul 24 08:36:56 CEST 2008

Hash: SHA1

Somebody in the thread at some point said:
| root at om-gta02:~# opkg upgrade
| Upgrading kernel-module-ext2 on root from 1:2.6.24+git20080424-r0 to
| 2:2.6.24+git20+287b292cf95edbd82dc63085ae5f0167a6e8141f-r0...
| Collected errors:
|  * ERROR: Package kernel-module-ext2 (parent kernel-module-ext2) is
| not available from any configured src.
|  * Failed to download kernel-module-ext2. Perhaps you need to run
'opkg update'?
| I've run the update, this has been around for a couple days.  Is this
| package important?

This is OK in itself... I moved ext2 and ext3 support into the
monolithic kernel so we can now do ext2 / 3 SD Card boot.  You need to
update the bootloader to play that game (but, it is a really fun game).

What the effect of that is on the package state with opkg is I dunno.
rpm (that I do know) has "obsoletes" tag one would add to the main
kernel package so it would have deleted the ext2 module package on upgrade.

- -Andy
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org


More information about the community mailing list