What is Exposure?

Christopher White chris at grierwhite.com
Thu Jul 24 19:23:18 CEST 2008

On Thu, 2008-07-24 at 11:45 -0400, Jeff Tickle wrote:
> On Thu, 24 Jul 2008 15:20:53 +0000
> Christopher White <chris at grierwhite.com> wrote:
> > I'm running stock ASU package set, just did an opkg update and
> > upgrade. I launch "Exposure" from the front screen, get the "Starting
> > Exposure" at the bottom, but then nothing.
> I had the same problem.  Looks like a packaging bug or something.

Wow...found this little gem (see below) in a different thread about the
ASU keyboard.  Once I switched to the new opkg feeds, exposure works
just fine.

Thanks for packaging it up Michael.  BTW, where did you find this info
about the feeds?  I didn't see anything like this on the wiki?


On Thu, 2008-07-24 at 17:18 +0100, Michael Sheldon wrote: 
> > Of course there's a mention of using some ASU image from
> > downloads.openmoko.org instead of buildhost.openmoko.org, but I can't
> > find anything ASU-related after sometime in May on the downloads site.
>   I had the same issue, the problem is that buildhost isn't building ASU 
> packages from the ASU dev git tree (I'd guess because it's mostly aimed 
> at people running 2007.02). What you need to do is change your opkg 
> feeds to use http://downloads.openmoko.org/openmoko-repository/ASU/ 
> which has all the new packages (including an updated version of qpe with 
> keyboard support enabled). You can download the correct config files from:
> http://www.mikeasoft.com/~mike/opkg-asu.tar.gz
>   Just move /etc/opkg to /etc/opkg-backup then unpack that to /etc, 
> then: opkg update && opkg upgrade && /etc/init.d/xserver-nodm restart
>   The keyboard should now pop up automatically when text areas request it.
> > I tried editing the
> > file /usr/share/enlightenment/data/themes/illume.edj and setting
> > 'visible: 1' under the 'part { name: "kbdtext"' section, but that
> > caused the whole UI to be useless (looks like this file is some sort of
> > compiled binary, I couldn't find any information on it.)
> > 
> > So, in short: what is up with the keyboard?
>   You can grab an illume theme with the qwerty button restored from:
> http://www.mikeasoft.com/~mike/illume.edj
>   Just drop that in to /usr/share/enlightenment/data/themes/ (note that 
> you'll need to overwrite it again each time illume-theme is updated though).

More information about the community mailing list