ASU Keyboard yet again

Michael Sheldon mike at
Thu Jul 24 19:54:09 CEST 2008

simarillion wrote:
> Thank you,
> it works fine, but how can I switch to the full keyboard which has not only 
> the letters? Do I need an additional package?

  Drag your finger upwards (or downwards) and you'll cycle through the 
layouts (lower case, upper case, symbols, numbers).


> Greets
> Michael
> Am Donnerstag 24 Juli 2008 18:18:52 schrieb Michael Sheldon:
>> Jeff Tickle wrote:
>>> Hey all,
>>> I just installed the ASU daily build from buildhost yesterday (23 Jul),
>>> and there doesn't seem to be an on-screen keyboard.
>>> I've been doing a lot of searching around to find out what's up with
>>> the keyboard.  I know that it was added as a 'qwerty' button, and then
>>> removed because the devs want it to automatically appear when there's
>>> text to enter and automatically disappear appropriately.  I'd
>>> personally prefer the manual mode, but I can understand why someone
>>> would want this done automatically.
>>> Problem for me is that the keyboard never automatically pops up.  I
>>> know this isn't an isolated incident, as this bug report exists:
>>> Of course there's a mention of using some ASU image from
>>> instead of, but I can't
>>> find anything ASU-related after sometime in May on the downloads site.
>>   I had the same issue, the problem is that buildhost isn't building ASU
>> packages from the ASU dev git tree (I'd guess because it's mostly aimed
>> at people running 2007.02). What you need to do is change your opkg
>> feeds to use
>> which has all the new packages (including an updated version of qpe with
>> keyboard support enabled). You can download the correct config files from:
>>   Just move /etc/opkg to /etc/opkg-backup then unpack that to /etc,
>> then: opkg update && opkg upgrade && /etc/init.d/xserver-nodm restart
>>   The keyboard should now pop up automatically when text areas request it.
>>> I tried editing the
>>> file /usr/share/enlightenment/data/themes/illume.edj and setting
>>> 'visible: 1' under the 'part { name: "kbdtext"' section, but that
>>> caused the whole UI to be useless (looks like this file is some sort of
>>> compiled binary, I couldn't find any information on it.)
>>> So, in short: what is up with the keyboard?
>>   You can grab an illume theme with the qwerty button restored from:
>>   Just drop that in to /usr/share/enlightenment/data/themes/ (note that
>> you'll need to overwrite it again each time illume-theme is updated
>> though).
>>   Cheers,
>>    Mike.
>> _______________________________________________
>> Openmoko community mailing list
>> community at
> _______________________________________________
> Openmoko community mailing list
> community at

More information about the community mailing list