strange problem with Intenso 4GB SDHC card

AVee openmoko-comunity at
Fri Jul 25 02:06:18 CEST 2008

On Thursday 24 July 2008 08:39, Doug Jones wrote:
> Mikael Berthe wrote:
> > * Doug Jones <dj6mf at> [2008-07-24 01:21 +0200]:
> >> There have been some indications that partition type may have some
> >> effect on this problem on the OLPC.
> >
> > I doubt it.
> >
> >> So, shrink the default vfat partition that came on the card and put
> >> an ext3 on there too.  If you want to be adventurous, try some other
> >> types.
> >
> > Happens to me with ext3 partitions as well (or mixed vfat/ext3
> > partitions).
> >
> > However if I restore the partition table the data are not corrupted,
> > at least so far it's been all right...
> Most people who use SD cards on OLPC are leaving them formatted as vfat,
> because Sugar can't see any other type.  I don't recall seeing any
> reports of partition table mangling from these people, who are the vast
> majority of OLPC users.
> It's when they try something other than vfat that the corruption occurs.
>   When it happened to me, I had one vfat and one ext3 on there.
> So on the OLPC at least, the corruption does seem to be correlated with
> partition type.

I haven't been able to find a publicly available version of any SD Card or 
SDHC spec. But both of the documents below seem to suggest that fat32 is part 
of the specification:

If that is the case both the controller and logic on the card may assume it 
contains a single full-size fat32 partition. They surely will not be tested 
with anything other then fat32. 

Does anyone here have access to official specs from the SDCard Association? It 
be interesting to have at least a hint about what the spec says about 


I always finish what I...

More information about the community mailing list