Firewall blocks USB ethernet

Andrew Bruno aeb at
Sat Jul 26 17:22:56 CEST 2008

"Scott Derrick" <scott at> writes:
> I finally have my FR's, WOOOOHOOOO!
> Got USB networking set up but I have to shutdown my firewall to get it
> to work?
> I'm using Ubuntu Hardy, and Firestarter as the firewall iptable  mananger.
> Anybody know of a How-to that can tell me how to setup my system to
> allow usb networking through the firewall?

You have to enable internet connection sharing for usb0. Try doing the
following in Firestarter:

- Edit -> Preferences -> Firewall -> Network Settings
- Set 'Local network connected device' to:  Unknown device (usb0)
- Check 'Enable internet connection sharing'

Hope that helps.


More information about the community mailing list