'hwclock' not working? (ASU)

Christopher White chris at grierwhite.com
Sat Jul 26 23:25:14 CEST 2008

On Sat, 2008-07-26 at 22:33 +0200, Holger Freyther wrote:
> On Saturday 26 July 2008 20:55:15 Christopher White wrote:
> > I ran into the same issue.  After running the above link, I also had to
> > stop the atd daemon which had /dev/rtc0 open:

> We run atd on the ASU image on purpose. It allows to schedule any kind of 
> alarms and will program the RTC for wakeup automatically. If you want atd to 
> write the current time into the rtc then you have to write "W\n" 
> into /var/spool/at/trigger.
> But on the other hand we provide a GUI application to set the Timezone and the 
> Time and they work.... :)

Well...I was baffled by setting the time from this.  I modified the
hour, clicked "Back" and it skipped forward several hours.  Went back
and forth trying to figure out what I was missing.  

I suspect it was because I had changed the Timezone but not rebooted yet
so I was in the limbo of /etc/localtime saying EDT, but date still
reporting UTC.  It now seems to work correctly, but this might need to
be looked at.  Next time I reflash, I'll try it again and see if I can't
better figure out the issue.


More information about the community mailing list