Flashing ASU Image

Christopher White chris at grierwhite.com
Sun Jul 27 15:24:44 CEST 2008

On Sun, 2008-07-27 at 14:42 +0200, Michael Münch wrote:
> Quoting arne anka <openmoko at ginguppin.de>:
> >> I think the more changes in basic packages as gtk+<-> gtk+-fastscaling
> >> there are, the superior the packetmanagement has to be. Resolving the
> >> dependencies, removing old files and so on. I am not sure if opkg can
> >> do the job perfectly that you have the same result as a clean image
> >
> > rather a case for improving opkg, isn't it?
> Although improving is always a good idea, this would be the case when  
> my thoughts, that taking an fairly old image and updating with opkg  
> could cause trouble, are correct. I don't know if they are.
> So the question should be is this method (image + opkg upgrade) in our  
> special case, opkg as a packetmanagement tool and the rapid changes of  
> ASU, the best solution?
> If I am wrong and this is the way to go, I am more than happy with it.

So I don't know if it's opkg related or not, but here's what I tried
yesterday with ASU:

1. Flash openmoko-qtopia-x11-image-om-gta02.jffs2 from the latest that I
could find (7/22):


2. Changed all opkg conf files to point to:


3. opkg update && opkg upgrade

4. Tried to get the qwerty keyboard enabled with the button.  Honestly
can't find which set of directions I used, as there were multiple emails
about this.  I did use the illume.edj replacemenet to get the button.

Things were very unstable:

- Applications sometimes appeared not to launch (no starting message).
Finally a good 30s later, the app popped up.  This seemed to come and

- qwerty button didn't seem to work

- finally got the "qpe died - your phone won't work..." dialog box

- exposure does not work (known issue now, but still makes it difficult)

I apologize for the lack of detail, but I spent most of the day
yesterday trying to get some of this stuff to work.  Switching from
multiple descriptions in different web pages, trying to decipher whether
it applies to 2007.2 or ASU, digging through email archives, etc.  

I like the way ASU is starting to come out, but man, it's driving me
nuts.  I finally just reflashed back to 2007.2 and I'll try again in a
week or so.


More information about the community mailing list