headset with qtopia

thewtex matthew.m.mccormick at gmail.com
Sun Jul 27 21:22:29 CEST 2008

Lorn Potter <lpotter at ...> writes:

> > Now question would be, how to make qtopia to recognize the headset has
> > been plugged in and change mixer settings accordingly. The .state files
> > in /usr/share/openmoko/scenarios are in place but don't seem to be used.
> Ok, I fixed headphone insertions today, and will make an image update 
> soon at qtopia.net

Thanks much for taking a look at this, Lorn.

I have flashed the new kernel/rootfs from qtopia
qtopia-4.3.2-gta02-flash-07221045.tgz, but I am still having difficulties.  

On initiation of a call, state switches to gsmhandset.state, regardless of
whether the headset is plugged in before or during the call.  

If I manually apply alsactl -f gsmheadset.state, I get working sound.

In the options popup tab during the call, only Handset and Speakerphone are
given, with Handset highlighted.

When I start a call with the headset, Headphones is in the Options menu, but as
soon as I plug the headset in, it disappears.

working on a GTA02v5

More information about the community mailing list