Errors compiling with toolchain

Robert William Hutton rwh at
Thu Jul 31 09:46:51 CEST 2008

Steven <montgoss at> wrote:
> I think these errors are generic, even though I get them when trying
> to compile openmoko-panel-alarm (since I don't see an ipkg available).
> When I run om-conf I get the following errors:
>  checking for GTK... configure: error: Package requirements
> (gtkmm-2.4 >= 2.8) were not met:
>  Package pthread-stubs was not found in the pkg-config search path.
>  Perhaps you should add the directory containing `pthread-stubs.pc'
> to the PKG_CONFIG_PATH environment variable
>  Package 'pthread-stubs', required by 'XCB', not found
> I think my system has a newer version of gtkmm, but om-conf is using
> the toolchain's version.  Or am I misunderstanding?  How do I fix
> that?  Same for pthread-stubs.  It's installed on my system.

I've also tried to build openmoko-panel-alarm and I ran into the same 
problems.  I don't think the build environment includes gtkmm, and there 
certainly isn't a gtkmm package in the default repositories either.

Does anyone know of a gtkmm package?  Otherwise I guess I'll try 
compiling and installing gtkmm from the upstream sources.

Haven't looked at pthread-stubs yet.

> Any help would be greatly appreciated.  I use my cellphone as my alarm
> and really want on working on my FreeRunner.

Yeah, me too.  This is the last killer feature the lack of which is 
stopping me switching over to the freerunner as my everyday phone.



More information about the community mailing list