Al Johnson openmoko at
Mon Jun 2 21:17:27 CEST 2008

On Monday 02 June 2008, Mathieu Rochette wrote:
> Hello,
> I recently discover the foxytag
> project<>. I'm wondering if
> this apps could run on the freerunner, if so I'll
> definitly buy one :D
> amAze <> will soon integrate foxytag but
> I think the software requierement are the same as each apps is a
> java-based.
> I don't know if a jvm is available for openmoko, and I think that maybe
> java apps for mobile phone require specific library.
> can anyone tell me a bit about all this ?
> thx, Mathieu.

For FoxyTag the MIDP2 and CLDC requirements look to be covered, but there is 
no mention of JSR-82 (Java Bluetooth API) and the FAQ says only Bluetooth GPS 
is supported. This may give rise to the daft situation of having to use an 
external GPS unit despite an internal one being present.

amAze is supposed to work with internal GPS so there's a good chance of it 

This is speculation from looking at the docs as I don't have a Freerunner to 
try it with...yet ;-)

More information about the community mailing list