help needed on Nonworking/gtk+-directfb

ywkhong ywkhong at
Mon Jun 16 06:34:06 CEST 2008

I'm new to OpenMoko and would like to seek for help on gtk+directfb.
I'd like to know if anyone had successfully build the OpenMoko with
gtk+-directfb before.

First approach:
I convert all the *.conf with:
  PREFERRED_PROVIDER_gtk+   ?= "gtk+-directfb"
It failed to include the gtk+-directfb as it conflict with other packages
that depends on gtk+ such as libgpewidget, webkit, openmoko-browser,
task-openmoko-pim, vte, xoo, fstests, etc

second approach:
start building the OpenMoko from stratch again with local.conf :
  DISTRO_EXTRA_RDEPENDS += "pkgconfig directfb cairo-directfb gtk+-directfb
and it failed as well.

Much appreciates on pointing me on how to get the gtk+-directfb work on the

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the community mailing list