Web based WIFI authentication

"Marco Trevisan (Treviño)" mail at 3v1n0.net
Mon Nov 3 17:14:13 CET 2008

W.Kenworthy wrote:
 > On Tue, 2008-10-28 at 07:31 +1300, Robin Paulson wrote:
>> 2008/10/28 Leonti Bielski <prishelec at gmail.com>:
>>> A lot of WIFI networks uses web based authentication - network is open, you
>>> connect to it, but in order to actually use internet you have to provide
>>> some login and password.
>>> How do you deal with that?
>>> I have a problem with all browsers:
>>> Minimo - it loads login page allright, than asks to accept certificate
>>> (login page is ssl encrypted) and crashes every time.
>>> Midori - doesn't react at all - like connection is broken (does it work with
>>> ssl and all this certificate stuff?).
>>> Dillo - doesn't support ssl at the time.
>>> Does anyone experiense same problem?
>>> Leonti
>> yup, had exactly the same problems, with ssl not being accepted using gmail
>> it's not critical, so i'm consigned to waiting till it and a myriad of
>> other bugs are fixed. frustrating i know
>> did you know there's a workaround to get dillo to do ssl? it requires
>> a re-compile, but doesn't appear too complicated
>> or maybe you could give fennec a go?
> I think links works with ssl ...

Same problem here. I've made some tries to get this working, and I found
the origin of the issue, but I didn't managed to get it fixed.

By the way... I've compiled om-browser and newer webkit using the
Openmoko Toolchain, I've put these in Om2008 but I wasn't able to login
in my wifi network.
So I run debian, there I was able to log-in using firefox and midori,
but I tried to use my newer webkit library (compiled under Om) to see if
it was the cause of our problem... It wasn't.

So, after some tries I got that the problem affects only the OE based
distros and that to be more precise libcurl or libgutls cause this issue.
I had the same problem also logging-in on Facebook from a webkit based
browser, so I filled a bug that later I said as unvalid; it could give
you more info [1].

PS: Fennec would work, the main problem is that it's really hard to
accept a bad certificate there. I got it working only opening it in
remote using SSH.

[1] https://bugs.webkit.org/show_bug.cgi?id=21389

Treviño's World - Life and Linux

More information about the community mailing list