USB Networking

Matthias Camenzind m.camenzind at
Thu Nov 6 18:54:09 CET 2008

I had also some problems with the Usb networking with ubuntu 8.04. But i could solve it with this: ifconfig usb0 netmask 
I had to enter it every time after i connected FR with my Computer or I rebooted the FR. But it worked fine. I found this solution in the Getting Started Guide for Neo 1973.
Today network is automatically set up after connecting but today I don't know exactly what I did.

-----Original Message-----
From: Denis Johnson <denis.johnson at>
Sent: 11/6/2008 1:06:23 PM
To: List for Openmoko community discussion <community at>
Subject: Re: USB Networking

On Thu, Nov 6, 2008 at 9:06 PM, Tony Berth <tonyberth at> wrote:
> the wiki posted solution was tested by myself on a the currebt debian and
> did work! Are you using the same environment?

I believe so, I'm using Ubuntu 8.10 but have had this problem since 8.04.

> On Thu, Nov 6, 2008 at 10:46 AM, Denis Johnson <denis.johnson at>
> wrote:
>> I have had this setting for months it does not work for me.
>> Whenever I want to connect my FR, I must first plug it in into the usb
>> and then run the following script which someone once posted here or on
>> the #openmoko irc. Until I run ths script I cannot ping and hence ssh
>> into the FR. Unfortunately I don't know enough to integrate and
>> automate what the script does into my interfaces file. If someone can
>> shed some more light, it would be appreciated:
>> ----------------------------------
>> #!/bin/sh
>> # Enables Hostside USB-Networking for neo
>> ifconfig usb0 down
>> ifconfig usb0 netmask up
>> iptables -A POSTROUTING -t nat -j MASQUERADE -s
>> echo 1 > /proc/sys/net/ipv4/ip_forward
>> iptables -P FORWARD ACCEPT
>> route add -host gw
>> route -n | grep -e "Destination" -e "usb0"
>> ----------------------------------

Openmoko community mailing list
community at

More information about the community mailing list