[QtExtended] Bluetooth car handsfree in 4.4.2

Benedikt Bär beniwtv at relamp.tk
Thu Nov 6 21:21:17 CET 2008

Hi list,

I was wondering if anyone could help me figure out the last missing
pieces of a puzzle :)

I'm trying to use my bluetooth car handsfree under QT Extended, and so
far made good progress.

Using the 2.6 kernel from the android download, the rfcomm bug in the
bluetooth driver seems to be solved.

With this kernel, I am able to pair, and 100% of the features of the car
handsfree do work, e. g. an incoming call is registered and I am able to
answer, outgoing calls made through booth Qtopia Dialer and the handset
work, etc...

But the problem is I get no sound - at no end of the call. 

So I saw from the Qtopia logs that the state file was missing, and I
downloaded one from this [1] page, confirmed to work.

Now I get static noise in the headset, which I suppose is a good thing
(tm) :), but still no sound. In a call, I've tried to change alsamixer,
but to no avail.

That leads me to suspect that it's not an alsa problem at all. I instead
think that Qtopia is not routing the audio properly.

So my question is: How does Qtopia handle audio via bluetooth, is it
like described in [1]? Do I need some alsa/bluez tweaking (not state
files) here? Has anyone tried this yet?

I strongly believe this can work and that I am on the right path. It
seems it's just something silly I'm missing :(


[1] http://wiki.openmoko.org/wiki/Manually_using_Bluetooth#Bluetooth_Headset_on_Freerunner


This e-mail is digitally signed by a PGP key, to verify it's authenticity.
If you received this e-mail without key the e-mail may not be authentic.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part
Url : http://lists.openmoko.org/pipermail/community/attachments/20081106/b695f359/attachment.pgp 

More information about the community mailing list