[android] new version with page flipping corrected.

Cédric Berger cedric.berger74 at gmail.com
Wed Nov 12 09:23:57 CET 2008

On Tue, Nov 11, 2008 at 18:17, akurpiel <andrzej.kurpiel at gmail.com> wrote:

> Cédric Berger wrote:
>> - Bluetooth is also working now (well I could not really test yet, but
>> at least now it correctly scans available bluetooth devices).
>> - Still no luck with wifi ("unable to scan for networks").
>> - I could not have GPS working.
>> I tried with GPSTracker, but it keeps asking for GPS activation, which
>> I had done in Android settings.
>> (note that GPSTracker requires a key from its website, and since I had
>> no keyboard to enter it, I did the settings on the emulator then copy
>> GPSTracker setting files directly into my SD card )
>> - I tried the demo game  "Fishocopter". It works... but it uses "back"
>> button to control the game (so it is "Aux" button on Neo), and I found
>> no way to exit the game, since Aux button did not anymore end
>> application.
>> Is there a way to kill such an application ? Power button only allowed
>> me to shutdown....
> -  Blutetooth is working ( but we still need keyboard for secret pin)
>   No hidd command -  we cannot start play with BT keyboard.
> -  Wifi  is working " by hand":
>    -  copy working  wpa_supplicant.conf  to phone
>    -   login via adb shell
>    -  use  command    dhcpcd eth0
>    - check  and  write correct data to   " getprop"  and " sendprop ..."
>    -   included web browser  not start at all
>    - installed by   "adb install ... "    news reader is working  !!
> -  I think, important is:  keyboard ( virtual or/and bluetooth ) and working
> web browser

Well yes I too was stopped by blutetooth pin without keyboard.

I could finally connect adb and get some logs. So :

- Browser fails at launch because of Gears.
I renamed /data/data/com.android.browser/app_plugins/gears.so into
gears.back and the browser could start.
I had no internet connectivity, so could not test much further, but
zooming, adding pages... worked.

- GPS : I tried GPSTracker and AccuTracking apps, and both fail with :
GPSTracker :
E/LocationManagerService(  614): isProviderEnabled got exception:
E/LocationManagerService(  614): java.lang.IllegalArgumentException:

AccuTracking :
D/LocationManagerService(  614): _requestLocationUpdates: listener =
android.os.BinderProxy at 436379d0
E/LocationManagerService(  614): requestUpdates got exception:
E/LocationManagerService(  614): java.lang.IllegalArgumentException:
E/LocationManagerService(  614): 	at

- I first had mms auto retrieve activated, so I had a lot of
exceptions logged about trying to get mms message. Anyway I have no
wap config done so it cannot work, but I do not know if enough is
implemented / ported for this to work...

- I also tried AndNav, but it looks like it fails because there is no
google map application in this released image. Is Map application not
published by google, or does it need some porting ?
log :
W/dalvikvm( 1104): VFY: unable to find class referenced in signature
W/dalvikvm( 1104): VFY: unable to resolve new-instance 134
(Lcom/google/android/maps/GeoPoint;) in Lorg/andnav/ui/Preferences;
W/dalvikvm( 1104): VFY:  rejecting opcode 0x22 at 0x0026
W/dalvikvm( 1104): VFY:  rejected
W/dalvikvm( 1104): Verifier rejected class Lorg/andnav/ui/Preferences;
D/AndroidRuntime( 1104): Shutting down VM

More information about the community mailing list