[debian][neo1973] Forwarding GSM port to PC

Bartlomiej Zdanowski [Zdanek] b.zdanowski at autoguard.pl
Wed Nov 12 10:12:40 CET 2008

Michael 'Mickey' Lauer pisze:
> You can use the nc/pty combination for that as described in 
> http://unadventure.wordpress.com/2007/10/28/qpe-430-plus-qemu/
> Note though that due to some weird bug this doesn't work for multiplexing 
> mode :/
I took a solution mentioned in this article and worked perfectly for my 
Neo 1973.

 killall gsmd

 nc -l -p 5000 < /dev/ttySAC0 > /dev/ttySAC0

Only conditions is that you have to use Openmoko distro. I'm using 
latest Debian distro and I have old OM lying on Flash. Under Debian my 
modem hangs after manually connecting via cu from Phone, so the hack 
above doesn't work. I suppose the problem is connected with multiplexing 
bug that Mickey mentioned, as multiplexing in Debian is enabled .

So I used OM and it worked well. I can call my Neo's GSM modem from any 
network machine.

Best regards,
*Bartlomiej Zdanowski*
Lead Programmer
Product Research & Development Department
AutoGuard S.A.

Place of registration: Regional Court for the Capital City of Warsaw
Registration no.: 0000287629
Share capital: 1 059 000 PLN
Polish VAT and tax ID no.: PL1132219747
Omulewska 27 street
04-128 Warsaw
phone +48 22 611 69 23
www.autoguard.pl <http://www.autoguard.pl>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.openmoko.org/pipermail/community/attachments/20081112/e6fa795e/attachment.htm 

More information about the community mailing list