[FSO][M4] DOOM Running slow.

SCarlson scottrcarlson at gmail.com
Thu Nov 13 14:30:05 CET 2008

 I've noticed extremely slow performance while running Doom on FSO M4. I
tracked it down to the accelerometer code. (I turned off accel control in
the opendoom.cfg file and that fixed the speed issue). The code basically
opens /dev/event3 and reads from this. Should I be approaching the
accelerometer interface differently?? It is running horribly slow, can
anyone else confirm this?

I've also noticed running from desktop on the phone is also very slow with
accel turned off as well. When running a similar startup script from ssh, it
runs full speed (accel still turned off).

Is there anything obvious here regarding the way FSO operates that could
cause this? I'd like to discover the cause and implement a solution quickly.
(Do I need to be on DBUS requesting the resources I need/want?)

View this message in context: http://n2.nabble.com/-FSO--M4--DOOM-Running-slow.-tp1493922p1493922.html
Sent from the Openmoko Community mailing list archive at Nabble.com.

More information about the community mailing list