new Game for freerunner: xlogical

Sander van Grieken sander at
Thu Nov 13 18:00:39 CET 2008

On Thursday 13 November 2008 13:45:28 Aapo Rantalainen wrote:
> c) dependeries: libsdl-image-1.2-0
> my package:
> Depends: libsdl-1.2-0 (>= 1.2.9), libsdl-image-1.2-0 (>=1.2.3-r0)
> your package:
> Depends: libsdl-1.2-0 (>= 1.2.11), libc6 (>= 2.6.1),
> libsdl-image-1.2-0 (>= 1.2.6), libsdl-mixer-1.2-0 (>= 1.2.6),
> libstdc++6 (>= 4.1.2), libgcc1 (>= 4.1.2)

Hmm I cannot set a runtime dep on older versions; the dependency on older 
versions in a bitbake recipe is only used at compile time. The package it 
produces still automatically creates a dependency on the version it was 
compiled against.

This is the problem with posting binary packages. I compiled it using branch, which uses a newer version of SDL than 

So I'm not going to "fix" this. if you want to create a openmoko-stable 
compatible package you can use MokoMakeFile and use the recipe from


More information about the community mailing list