[Om2008.9] gsmspeakerout.state - headset working

Giovanni pino.otto at gmail.com
Thu Nov 20 12:41:41 CET 2008

What about the headset working on qt mediaplayer?

When I use the earphones with qt mediaplayer, the external speakers are
still working.
I don't know how to disable the loud speakers, in order to listen the sound
only through the earphones.

Any hint?

On Thu, Nov 20, 2008 at 8:48 AM, Tom Yates <madhatter at teaparty.net> wrote:

> On Wed, 19 Nov 2008, Matthias Apitz wrote:
> > one don't need extending the desktop to launch 'alsactl -f
> > gsmspeakerout.state restore'; when you're in a call there is a small
> > menue on the left buttom side called 'Options' which let you switch
> > between 'handset' and 'speakerout';
> you star!  from that, moving gsmspeakerout.state to one side and linking
> gsmheadset.state to gsmspeakerout.state means that, whilst i don't need
> speakerphone mode much, i can now switch to headset - which is very
> important for me - inside a call.
> i notice now that there's a headset option that shows up there
> *sometimes*, but it's less-easy to access than "speakerphone" and anyway
> it doesn't work as well.  perhaps it loads headset.state instead of
> gsmheadset.state?
> if anyone else wants the details, they're at
> http://www.teaparty.net/technotes/openmoko-2.html#Headset .
> interestingly, this has reduced the list of things that prevent my 'moko
> from being a perfectly good everyday phone to zero.
> --
>       Tom Yates  -  http://www.teaparty.net
> _______________________________________________
> Openmoko community mailing list
> community at lists.openmoko.org
> http://lists.openmoko.org/mailman/listinfo/community
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.openmoko.org/pipermail/community/attachments/20081120/31c708af/attachment.htm 

More information about the community mailing list